Website Pricing

Incident Report for Baldor Service

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 15:09 EDT

Update

We are continuing to monitor for any further issues.
Posted Mar 10, 2026 - 15:07 EDT

Monitoring

A recent change has been rolled back.
Posted Mar 10, 2026 - 15:06 EDT

Investigating

We are experiencing slowness in our pricing integration. As the result, customers may see all items as unavailable.
Posted Mar 10, 2026 - 14:45 EDT
This incident affected: Website.